Connectivity issues to nuget.org
Incident Report for AppVeyor
Resolved
Verizon Digital Media Services (CDN service used by Azure) has routed the network path to a different ISP which fixed the issue. The reason for the packet loss on that specific link is still being investigated by Verizon.
Posted 5 months ago. Jul 20, 2017 - 18:36 PDT
Update
We've deployed a workaround (along with other changes) to all three images: Visual Studio 2013, Visual Studio 2015 and Visual Studio 2017. Let us know if you are still experiencing the issues restoring nuget packages. In the mean time we continue working with Azure, Verizon and Rackspace on a permanent solution.
Posted 5 months ago. Jul 19, 2017 - 12:45 PDT
Identified
While working with NuGet, Azure and Rackspace teams on resolving this issue we are deploying a temporary workaround to build worker images.
Posted 5 months ago. Jul 18, 2017 - 20:34 PDT
Update
The issue is a "broken" route between Rackspace data center and US-based CDN edge server for api.nuget.org. Unfortunately, there is no ETA yet. We continue working with nuget team to resolve the issue as soon as possible.
Posted 5 months ago. Jul 17, 2017 - 21:59 PDT
Update
Temporary workaround is to redirect nuget restore to European CDN edge server by adding this to appveyor.yml:


hosts:
api.nuget.org: 93.184.221.200


If you are configuring your projects via UI you can add host mappings on "Environment" tab of project settings.

The fix above will work only if nuget restore command is run after install phase. To update hosts file before install phase please use the following solution:


init:
- ps: '[System.IO.File]::AppendAllText("C:\Windows\System32\drivers\etc\hosts", "`n93.184.221.200`tapi.nuget.org")'


Please note this is a temporary workaround that should be removed once the issue is resolved. Sorry for the inconveniences.
Posted 5 months ago. Jul 17, 2017 - 12:54 PDT
Investigating
We are investigating intermittent connectivity issues to api.nuget.org.
Posted 5 months ago. Jul 17, 2017 - 11:01 PDT